FANDOM


Gold Ingot


So Minecraft 1.8 has been out for almost a year, and the mod hasn't updated yet. I am sure some of you are wondering: Why not?

Well as you can see here, most mod authors have not updated to 1.8 yet, and I am seriously doubting ever doing so. This is because Mojang really pulled the rug out from under modders with 1.8 and the amount of work that needs to be done updating all the code to the new format - especially for a mod this size - is so large, it's debatable whether it's worth it.

To get a taste as to why, and some expert opinions on this, see herehere, here, here, and maybe do some research on your own.

A comment from one of those threads: "Here's a question for you: Why bother? What amazing features does 1.8 have to make modders spend months to port their mods to it in a stable manner?" - asiekierka, BuildCraft dev, 1 month ago

There is no pressing need to update. Minecraft 1.7.10 is still available, Forge is still available, everything is still here and it isn't going to stop working or go away. Yes, 1.7 has some horrendous chunk loading lag, but simply install FastCraft and the lag goes away completely!

The only things really worth updating for are the new commands, and even that is questionable. The benefits of any other 1.8 feature pale in comparison to the amount of work I would need to do. If you disagree with this, remember: I am the one who will have to do the updating, and I know how much work it would be; you don't. (Unless you are a modder yourself, but most people on here aren't.)

Here is a comment by HubToo which lays out even more reasons why updating to 1.8 wouldn't be good, from a server owner's perspective.

So, in conclusion, I may or may not update to 1.8 in the future. This also applies to 1.9 and any other future versions, since updating to them would mean going through 1.8. If I do ever update to 1.8, it certainly won't be any time soon. And as always: pestering me to do it won't make it happen faster.

Thank you all for reading, and thank you to the vast, vast majority of mod users who have been patient and not asked me to update to 1.8, or if they have asked, have not done so in an annoying way.